Let’s Encrypt 변경 사항

현재 사용하고 있는 SSL 인증서 (Let’s Encrypt) 설치는 스위프트 코딩에 나온 설명을 참조해서 적용했었다. 최근에 갱신을 하기 위해서 내용을 보니 다음과 같은 메시지가 나온다.

./certbot-auto has insecure permissions!
To learn how to fix them, visit
https://community.letsencrypt.org/t/certbot-auto-deployment-best-practices/91979/

인증서 갱신을 할 때 파일 접근 권한과 관련된 내용인데, 현재 인증서 관련 파일의 디렉토리 위치를 좀 더 안전한 곳으로 이동하라는 것으로 보인다.

문제는 해당 설명 문서가 너무 간단(?)하게 기술되어 있어서 내 시스템에 어떻게 적용해야 하는지 모르겠다. ㅜㅜ

또 하나 이슈는 워드프레스 내부 메뉴에서 현재 php 버전이 낮다고 버전을 올리라고 하는데 라이트세일에서는 그런 메뉴가 보이지 않는다.

이렇게 간단한 설치형 블로그를 운영하기 위해서도 신경써야 할 사항이 많고 복잡하기 때문에 간편한 사용성을 자랑하는 (그러나 속도가 느린) 워드프레스닷컴이나 여러 제약이 많지만 포털의 블로그 서비스를 이용하는 사람이 많은 것 같다.